Results 1 to 5 of 5

Thread: Sat Nav system has stopped working

  1. #1
    Join Date
    Jun 2017
    Location
    Elliminyt
    Posts
    16
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default Sat Nav system has stopped working

    The Columbus sat nav / radio system in my Octavia Scout has stopped working. Any clues?

    It stopped and started within the first couple of months after I purchased the car "new" / executive driven from a dealer in Melbourne.

    Did it about twice and has been fine ever since. Have read on other sites these can be problematic.

    Issue is no radio and my bluetooth phone connection won't work. The parking sensors till beep but no image to show me how close.

    I was going to check the fuses first but where the hell are they?

    SS.

  2. #2
    Join Date
    Jun 2017
    Location
    Elliminyt
    Posts
    16
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default

    Found the interior fuses but all the diagrams are for a LHD not RHD

    When I counted in reverse there was no fuse in the allocated spot (#28).

    What the ....

  3. #3
    Join Date
    Aug 2009
    Posts
    870
    Thanks
    8
    Thanked 44 Times in 30 Posts

    Default

    what about disconnecting the battery for a while, then reconnecting.... It could also be a loose connection on the battery..

  4. #4
    Join Date
    Jun 2017
    Location
    Elliminyt
    Posts
    16
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default

    I took it to a auto electrician as the dealer told me at the last service that the A/c compressor had failed (I posted separately about that). The A/c light is still on, cool air is coming out and the Auto Elec said it is working, not sure what the service guy is on about. He said if it had failed there would be no cool air.

    He then checked my fuses all were ok (both beside the door and under the bonnet). Also all the other electrics seem to be working. He tended to think it was the unit although he did query whether it may be something loose behind the dash. However he had never opened up the dash in one of these and was a bit reluctant.

    Don't think I'll go back to that dealer, they also lost my service book that I've had since the car was new, very unhappy with them right now.

    Think I'll need to go to another Skoda dealer or a Volks specialist that someone referred to for the compressor issue. Unless anyone has any other ideas.

  5. #5
    Join Date
    Aug 2009
    Posts
    870
    Thanks
    8
    Thanked 44 Times in 30 Posts

    Default

    yeah, time to find a new dealer/independent..

    I would say scan the car with vcds/vagcom is always the best first step to see if there are any errors..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •